Access Restriction Bypass Affecting snipe/snipe-it package, versions <5.3.10


0.0
medium

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity Low
Expand this section
NVD
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-SNIPESNIPEIT-2401212
  • published 15 Feb 2022
  • disclosed 15 Feb 2022
  • credit shubh123-tri

How to fix?

Upgrade snipe/snipe-it to version 5.3.10 or higher.

Overview

snipe/snipe-it is an asset management system built on Laravel.

Affected versions of this package are vulnerable to Access Restriction Bypass due to missing authorization of the supplier viewing endpoint in SuppliersController.php.