Improper Privilege Management Affecting snipe/snipe-it package, versions <5.4.0


0.0
medium

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity Low
Expand this section
NVD
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-SNIPESNIPEIT-2401817
  • published 16 Feb 2022
  • disclosed 16 Feb 2022
  • credit ranjit-git

How to fix?

Upgrade snipe/snipe-it to version 5.4.0 or higher.

Overview

snipe/snipe-it is an asset management system built on Laravel.

Affected versions of this package are vulnerable to Improper Privilege Management due to missing authorization of edit/delete calls to the maintenances endpoint.

References