Information Exposure Affecting snipe/snipe-it package, versions <5.4.0


0.0
medium

Snyk CVSS

    Attack Complexity Low
Expand this section
NVD
5.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-SNIPESNIPEIT-2404308
  • published 17 Feb 2022
  • disclosed 17 Feb 2022
  • credit Binit Ghimire

How to fix?

Upgrade snipe/snipe-it to version 5.4.0 or higher.

Overview

snipe/snipe-it is an asset management system built on Laravel.

Affected versions of this package are vulnerable to Information Exposure via the response time of a request in the password reset page. A valid email address produces a response slower than an invalid email, thus allowing to enumerate addresses.

References