Information Exposure Affecting snipe/snipe-it Open this link in a new tab package, versions >=0.3.0-alpha, <5.3.8


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-PHP-SNIPESNIPEIT-2806416

  • published

    2 May 2022

  • disclosed

    2 May 2022

  • credit

    Unknown

How to fix?

Upgrade snipe/snipe-it to version 5.3.8 or higher.

Overview

snipe/snipe-it is an asset management system built on Laravel.

Affected versions of this package are vulnerable to Information Exposure due to Host Header Injection. By sending a specially crafted host header in the reset password request, it is possible to send password reset links to users which once clicked lead to an attacker-controlled server and thus leading to password reset token leak.

References