Uncontrolled Recursion Affecting symfony/expression-language package, versions <5.4.54>=6.0.0, <6.4.48>=7.0.0, <7.4.21>=8.0.0, <8.1.9


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.38% (32nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-PHP-SYMFONYEXPRESSIONLANGUAGE-21203958
  • published18 Oct 2026
  • disclosed15 Oct 2026
  • creditBruno Dias

Introduced: 15 Oct 2026

NewCVE-2026-109449  (opens in a new tab)
CWE-674  (opens in a new tab)

How to fix?

Upgrade symfony/expression-language to version 5.4.54, 6.4.48, 7.4.21, 8.1.9 or higher.

Overview

Affected versions of this package are vulnerable to Uncontrolled Recursion via the expression parser in Parser.php, which builds a node tree with no bound on nesting depth. An attacker can supply an expression containing tens of thousands of nested unary operators, array literals, binary operators, or property accesses; the expression parses successfully but the resulting tree causes a segfault on teardown, crashing the process. The fix introduces a maximum nesting level of 256 nodes on any single branch, enforced at both recursive-descent and iterative fold sites (parseExpression, parseConditionalExpression, parsePostfixExpression).

CVSS Base Scores

version 4.0
version 3.1