Access Restriction Bypass Affecting winter/storm package, versions <1.0.475 >=1.1.0, <1.1.9


0.0
high
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    Low

  • Privileges Required

    High

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-PHP-WINTERSTORM-2952706

  • published

    17 Jul 2022

  • disclosed

    15 Jul 2022

  • credit

    David Miller

Introduced: 15 Jul 2022

CWE-284 Open this link in a new tab

How to fix?

Upgrade winter/storm to version 1.0.475, 1.1.9 or higher.

Overview

winter/storm is a Winter CMS Storm Library

Affected versions of this package are vulnerable to Access Restriction Bypass. When Safe Mode is in use, users with create or modify permissions can bypass it and modify PHP code of CMS theme template objects.

References