Access Control Bypass Affecting wp-graphql/wp-graphql Open this link in a new tab package, versions <0.3.5


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-PHP-WPGRAPHQLWPGRAPHQL-2812824

  • published

    10 May 2022

  • disclosed

    10 May 2022

  • credit

    Unknown

How to fix?

Upgrade wp-graphql/wp-graphql to version 0.3.5 or higher.

Overview

Affected versions of this package are vulnerable to Access Control Bypass as it doesn't properly restrict access to information about other users' roles on the affected site. Because of this, a remote attacker can forge a query to retrieve the account roles of every user on the site.