Server-side Request Forgery (SSRF) Affecting yeswiki/yeswiki package, versions <4.6.7


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.32% (24th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-PHP-YESWIKIYESWIKI-21717112
  • published26 Oct 2026
  • disclosed2 Oct 2026
  • creditUnknown

Introduced: 2 Oct 2026

NewCVE-2026-104442  (opens in a new tab)
CWE-918  (opens in a new tab)

How to fix?

Upgrade yeswiki/yeswiki to version 4.6.7 or higher.

Overview

Affected versions of this package are vulnerable to Server-side Request Forgery (SSRF) via the syndication process. An attacker can cause the server to fetch arbitrary URLs, potentially targeting internal hosts and ports, reading back fetched feed content in the rendered page, and causing feed enclosures to be downloaded into the files directory by supplying crafted input to the content parameter of the render handler.

References

CVSS Base Scores

version 4.0
version 3.1