Cross-site Request Forgery (CSRF) Affecting yeswiki/yeswiki package, versions <4.6.7


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.16% (5th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-PHP-YESWIKIYESWIKI-21717118
  • published26 Oct 2026
  • disclosed2 Oct 2026
  • creditUnknown

Introduced: 2 Oct 2026

NewCVE-2026-104448  (opens in a new tab)
CWE-352  (opens in a new tab)

How to fix?

Upgrade yeswiki/yeswiki to version 4.6.7 or higher.

Overview

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF) via the ajaxdeletepage handler when a GET request includes the jsonp_callback parameter without verifying a CSRF token. An attacker can cause permanent deletion of arbitrary pages, including their ACLs, links, triples, comments, and referrers, by tricking a logged-in administrator or page owner into visiting a crafted link.

References

CVSS Base Scores

version 4.0
version 3.1