Server-side Request Forgery (SSRF) Affecting yeswiki/yeswiki package, versions <4.6.7


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.36% (29th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-PHP-YESWIKIYESWIKI-21717119
  • published26 Oct 2026
  • disclosed2 Oct 2026
  • creditUnknown

Introduced: 2 Oct 2026

NewCVE-2026-104441  (opens in a new tab)
CWE-918  (opens in a new tab)

How to fix?

Upgrade yeswiki/yeswiki to version 4.6.7 or higher.

Overview

Affected versions of this package are vulnerable to Server-side Request Forgery (SSRF) via the valeur action's url parameter. An attacker can cause the server to initiate arbitrary HTTP requests to internal or external hosts and read response content by submitting crafted requests through the content parameter of handlers/page/render.php.

References

CVSS Base Scores

version 4.0
version 3.1