Server-side Request Forgery (SSRF) Affecting yeswiki/yeswiki package, versions <4.6.7


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.29% (20th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-PHP-YESWIKIYESWIKI-21717122
  • published26 Oct 2026
  • disclosed2 Oct 2026
  • creditUnknown

Introduced: 2 Oct 2026

NewCVE-2026-104440  (opens in a new tab)
CWE-918  (opens in a new tab)

How to fix?

Upgrade yeswiki/yeswiki to version 4.6.7 or higher.

Overview

Affected versions of this package are vulnerable to Server-side Request Forgery (SSRF) via the idtypeannonce parameter in the /api/entries/bazarlist endpoint. An attacker can cause the server to make arbitrary HTTP requests to internal or external resources by supplying crafted URLs, potentially allowing network probing or access to internal services.

References

CVSS Base Scores

version 4.0
version 3.1