Information Exposure Affecting zendframework/zend-feed Open this link in a new tab package, versions >=1.0.0, <2.10.3


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-PHP-ZENDFRAMEWORKZENDFEED-2805806

  • published

    29 Apr 2022

  • disclosed

    28 Apr 2022

  • credit

    Drupal Security Team

Introduced: 28 Apr 2022

New CWE-200 Open this link in a new tab

How to fix?

Upgrade zendframework/zend-feed to version 2.10.3 or higher.

Overview

Affected versions of this package are vulnerable to Information Exposure. Marshaling a request URI includes logic that introspects HTTP request headers that are specific to a given server-side URL rewrite mechanism. When these headers are present on systems not running the specific URL rewriting mechanism, the logic would still trigger, allowing a malicious client or proxy to emulate the headers to request arbitrary content.