Remote Code Execution (RCE) Affecting accesscontrol package, versions [5.0, 5.2) [4.0, 4.3)


0.0
medium

Snyk CVSS

    Attack Complexity High
    Privileges Required High
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 0.87% (82nd percentile)
Expand this section
NVD
7.2 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PYTHON-ACCESSCONTROL-1535295
  • published 1 Aug 2021
  • disclosed 1 Aug 2021
  • credit Unknown

How to fix?

Upgrade AccessControl to version 5.2, 4.3 or higher.

Overview

Affected versions of this package are vulnerable to Remote Code Execution (RCE). The package allows access to Python's string module, which then allows access to the Formatter class that can be overridden in a way that allows access to further unsafe Python libraries.

NOTE: This only applies to Python 3. Furthermore, only websites that allow untrusted users to edit Script (Python) are vulnerable.