SQL Injection Affecting apache-superset package, versions [,1.3.1)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-PYTHON-APACHESUPERSET-1759453

  • published

    19 Oct 2021

  • disclosed

    19 Oct 2021

  • credit

    Kevin Kusnardi

How to fix?

Upgrade apache-superset to version 1.3.1 or higher.

Overview

apache-superset is a modern, enterprise-ready business intelligence web application.

Affected versions of this package are vulnerable to SQL Injection. When configured with ENABLE_TEMPLATE_PROCESSING on (disabled by default) it allowed SQL injection when a malicious authenticated user sends an http request with a custom URL.