Insufficiently Protected Credentials Affecting apache-superset package, versions [,1.4.0)


0.0
medium

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
Expand this section
NVD
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PYTHON-APACHESUPERSET-2399202
  • published 11 Feb 2022
  • disclosed 2 Feb 2022
  • credit Cesar Santos

How to fix?

Upgrade apache-superset to version 1.4.0 or higher.

Overview

apache-superset is a modern, enterprise-ready business intelligence web application.

Affected versions of this package are vulnerable to Insufficiently Protected Credentials which allows registered database connections password leak for authenticated users.

References