Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') Affecting apache-superset package, versions [,1.5.3) [2.0.0,2.0.1)


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required

    Threat Intelligence

    EPSS 0.08% (34th percentile)
Expand this section
NVD
5.4 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PYTHON-APACHESUPERSET-3244381
  • published 22 Jan 2023
  • disclosed 16 Jan 2023
  • credit Unknown

How to fix?

Upgrade apache-superset to version 1.5.3, 2.0.1 or higher.

Overview

apache-superset is a modern, enterprise-ready business intelligence web application.

Affected versions of this package are vulnerable to Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') due to improper escape of HTML characters, which allows creating a record with specific HTML tags, that will trigger the exploitation via the toast message displayed when the user deletes the crafted CSS template record.

NOTE: Exploiting this vulnerability is possible by an authenticated attacker with write CSS template permissions.