Server-side Request Forgery (SSRF) Affecting apache-superset package, versions [,2.1.0)


0.0
medium

Snyk CVSS

    Attack Complexity Low
    Confidentiality High

    Threat Intelligence

    EPSS 0.06% (27th percentile)
Expand this section
NVD
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PYTHON-APACHESUPERSET-5759282
  • published 7 Jul 2023
  • disclosed 6 Jul 2023
  • credit Alexey Sabadash

How to fix?

Upgrade apache-superset to version 2.1.0 or higher.

Overview

apache-superset is a modern, enterprise-ready business intelligence web application.

Affected versions of this package are vulnerable to Server-side Request Forgery (SSRF). A malicious actor who has been authenticated and granted specific permissions in Apache Superset may use the import dataset feature in order to conduct Server-Side Request Forgery attacks and query internal resources on behalf of the server where Superset is deployed.

References