Improper Preservation of Permissions Affecting apache-superset package, versions [,2.1.1)


0.0
medium

Snyk CVSS

    Attack Complexity Low

    Threat Intelligence

    EPSS 0.06% (27th percentile)
Expand this section
NVD
5.4 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PYTHON-APACHESUPERSET-5892779
  • published 12 Sep 2023
  • disclosed 6 Sep 2023
  • credit Miguel Segovia Gil

How to fix?

Upgrade apache-superset to version 2.1.1 or higher.

Overview

apache-superset is a modern, enterprise-ready business intelligence web application.

Affected versions of this package are vulnerable to Improper Preservation of Permissions. An improper default REST API permission for Gamma users allows for an authenticated Gamma user to test database connections.