Incorrect Authorization Affecting apache-superset package, versions [,2.1.2)


0.0
medium

Snyk CVSS

    Attack Complexity High
    Scope Changed
    Integrity High

    Threat Intelligence

    EPSS 0.5% (76th percentile)
Expand this section
NVD
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PYTHON-APACHESUPERSET-6092413
  • published 29 Nov 2023
  • disclosed 27 Nov 2023
  • credit LEXFO for Orange Innovation, Orange CERT-CC

How to fix?

Upgrade apache-superset to version 2.1.2 or higher.

Overview

apache-superset is a modern, enterprise-ready business intelligence web application.

Affected versions of this package are vulnerable to Incorrect Authorization. An attacker can escalate privileges and tamper with authentication/authorization data by using a specially crafted CTE SQL statement.

Note:

This is only exploitable if the default "examples" database connection is used, which allows access to both the examples schema and the metadata database.