Incorrect Authorization Affecting apache-superset package, versions [,2.1.3) [3.0.0,3.0.2)


0.0
high

Snyk CVSS

    Attack Complexity Low
    Scope Changed
    Integrity High

    Threat Intelligence

    EPSS 0.05% (14th percentile)
Expand this section
NVD
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PYTHON-APACHESUPERSET-6132132
  • published 20 Dec 2023
  • disclosed 19 Dec 2023
  • credit Jordan Velich

How to fix?

Upgrade apache-superset to version 2.1.3, 3.0.2 or higher.

Overview

apache-superset is a modern, enterprise-ready business intelligence web application.

Affected versions of this package are vulnerable to Incorrect Authorization due to improper enforcement of access controls. An authenticated Gamma user can exploit this by creating a dashboard and adding charts to it, which erroneously grants them ownership and write permissions to those charts.