Cryptographic Issues Affecting aqtinstall Open this link in a new tab package, versions [,2.1.0rc2)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-PYTHON-AQTINSTALL-2803420

  • published

    26 Apr 2022

  • disclosed

    26 Apr 2022

  • credit

    Unknown

Introduced: 26 Apr 2022

CWE-310 Open this link in a new tab

How to fix?

Upgrade aqtinstall to version 2.1.0rc2 or higher.

Overview

aqtinstall is an Another unofficial Qt installer

Affected versions of this package are vulnerable to Cryptographic Issues by using the random module to generate numbers, instead of 'secrets', which is less cryptographically secure.