Cryptographic Issues Affecting argo-workflows Open this link in a new tab package, versions [,6.3.0rc2)


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-PYTHON-ARGOWORKFLOWS-2774704

  • published

    24 Apr 2022

  • disclosed

    24 Apr 2022

  • credit

    Unknown

Introduced: 24 Apr 2022

CWE-310 Open this link in a new tab

How to fix?

Upgrade argo-workflows to version 6.3.0rc2 or higher.

Overview

argo-workflows is an Argo Workflows API

Affected versions of this package are vulnerable to Cryptographic Issues by using versions of TLS protocols lower than 1.2.