SQL Injection Affecting bigdl package, versions [,2.3.0)


0.0
medium

Snyk CVSS

    Attack Complexity Low
    Scope Changed

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PYTHON-BIGDL-5591079
  • published 21 May 2023
  • disclosed 21 May 2023
  • credit Unknown

Introduced: 21 May 2023

CVE NOT AVAILABLE CWE-89 Open this link in a new tab

How to fix?

Upgrade bigdl to version 2.3.0 or higher.

Overview

bigdl is a Building Large-Scale AI Applications for Distributed Big Data

Affected versions of this package are vulnerable to SQL Injection due to users having direct access to file python/benchmark/run.py, which allows them to pass arguments to change the SQL contents.