Insufficient Verification of Data Authenticity Affecting certifi package, versions [,2022.12.7)


0.0
medium

Snyk CVSS

    Attack Complexity Low
    Privileges Required High
    Scope Changed
    Integrity High
Expand this section
NVD
7.5 high
Expand this section
SUSE
6.6 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PYTHON-CERTIFI-3164749
  • published 8 Dec 2022
  • disclosed 7 Dec 2022
  • credit Joel Reardon

How to fix?

Upgrade certifi to version 2022.12.7 or higher.

Overview

Affected versions of this package are vulnerable to Insufficient Verification of Data Authenticity resulting in Certifi root certificate removal from TrustCor. The root certificates are being removed pursuant to an investigation prompted by media reporting that TrustCor's ownership also operated a business that produced spyware.