Information Exposure Affecting glances Open this link in a new tab package, versions [,3.2.5)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-PYTHON-GLANCES-2932162

  • published

    20 Jun 2022

  • disclosed

    20 Jun 2022

  • credit

    Unknown

Introduced: 20 Jun 2022

New CWE-200 Open this link in a new tab

How to fix?

Upgrade Glances to version 3.2.5 or higher.

Overview

Glances is an A cross-platform curses-based monitoring tool

Affected versions of this package are vulnerable to Information Exposure due to logging of passwords in the load method of the GlancesPasswordList class. Exploiting this vulnerability could potentially let a local user the ability to view all passwords stored by Glances.