Improper Input Validation Affecting ipaddress package, versions [0,]


0.0
high

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity High
    Integrity High
    Availability High
Expand this section
SUSE
8.6 high
Expand this section
NVD
9.8 critical
Expand this section
Red Hat
9.1 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PYTHON-IPADDRESS-1290073
  • published 6 May 2021
  • disclosed 30 Apr 2021
  • credit Unknown

How to fix?

There is no fixed version for ipaddress.

Overview

ipaddress is an IPv4/IPv6 manipulation library

Affected versions of this package are vulnerable to Improper Input Validation. Improper input validation of octal strings in stdlib ipaddress allows unauthenticated remote attackers to perform indeterminate SSRF, RFI, and LFI attacks on many programs that rely on Python stdlib ipaddress. The highest threat from this vulnerability is to data integrity and system availability.