Snyk has a proof-of-concept or detailed explanation of how to exploit this vulnerability.
The probability is the direct output of the EPSS model, and conveys an overall sense of the threat of exploitation in the wild. The percentile measures the EPSS probability relative to all known EPSS scores. Note: This data is updated daily, relying on the latest available EPSS model version. Check out the EPSS documentation for more details.
In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.
Test your applicationsLearn about Server-side Request Forgery (SSRF) vulnerabilities in an interactive lesson.
Start learningUpgrade lightrag-hku to version 1.5.5 or higher.
lightrag-hku is a LightRAG: Simple and Fast Retrieval-Augmented Generation
Affected versions of this package are vulnerable to Server-side Request Forgery (SSRF) via the _unwrap_embedded_ipv4 function in lightrag/parser/markdown/parser.py, where the RFC 8215 local-use NAT64 prefix 64:ff9b:1::/48 is incorrectly decoded by extracting the low 32 bits as the embedded IPv4 address. Because RFC 6052 §2.2 /48 encoding places the IPv4 in bits 48-63 and 72-87 rather than the low 32 bits, an attacker can supply an IPv6 address such as 64:ff9b:1:7f00:0:100:808:808 (a /48 encoding of 127.0.0.1) that is misread as the public address 8.8.8.8 and passes the SSRF filter, allowing requests to loopback, RFC 1918, or cloud metadata addresses. Conversely, a canonical public /48 encoding is misread as 0.0.0.0 and wrongly blocked.