Authorization Bypass Through User-Controlled Key Affecting oauthenticator Open this link in a new tab package, versions [,15.0.0)


0.0
medium
  • Attack Complexity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-PYTHON-OAUTHENTICATOR-2859767

  • published

    7 Jun 2022

  • disclosed

    6 Jun 2022

  • credit

    GeorgianaElena, yuvipanda

How to fix?

Upgrade oauthenticator to version 15.0.0 or higher.

Overview

Affected versions of this package are vulnerable to Authorization Bypass Through User-Controlled Key when using CILogonOAuthenticator which does not verify which provider is used by the user to login, only the email address provided.

References