Cryptographic Issues Affecting oic package, versions [,1.2.1)


0.0
low

Snyk CVSS

    Attack Complexity High

    Threat Intelligence

    EPSS 0.16% (51st percentile)
Expand this section
NVD
6.8 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PYTHON-OIC-1047572
  • published 1 Dec 2020
  • disclosed 1 Dec 2020
  • credit tpazderka

How to fix?

Upgrade oic to version 1.2.1 or higher.

Overview

Affected versions of this package are vulnerable to Cryptographic Issues due to the following:

  1. The IdToken signature algorithm was not checked automatically, but only if the expected algorithm was passed in as a kwarg.
  2. JWA none algorithm was allowed in all flows.
  3. oic.consumer.Consumer.parse_authz returns an unverified IdToken. The verification of the token was left to the discretion of the implementator.
  4. iat claim was not checked for sanity (i.e. it could be in the future)