Cleartext Storage of Sensitive Information Affecting py7zr package, versions [,0.6b5)


0.0
low

Snyk CVSS

    Attack Complexity Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PYTHON-PY7ZR-6096280
  • published 1 Dec 2023
  • disclosed 1 Dec 2023
  • credit Hiroshi Miura

Introduced: 1 Dec 2023

CVE NOT AVAILABLE CWE-312 Open this link in a new tab

How to fix?

Upgrade py7zr to version 0.6b5 or higher.

Overview

py7zr is a Pure python 7-zip library

Affected versions of this package are vulnerable to Cleartext Storage of Sensitive Information by handling passwords unencrypted.