Improper Validation Affecting pysaml2 package, versions [,6.5.0)


Severity

Recommended
0.0
medium
0
10

CVSS assessment made by Snyk's Security Team

    Threat Intelligence

    EPSS
    0.11% (44th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PYTHON-PYSAML2-1063039
  • published 20 Jan 2021
  • disclosed 20 Jan 2021
  • credit Victor Schönfelder Garcia, Juraj Somorovsky, Vladislav Mladenov

How to fix?

Upgrade pysaml2 to version 6.5.0 or higher.

Overview

pysaml2 is a Python implementation of SAML Version 2 Standard.

Affected versions of this package are vulnerable to Improper Validation. By default, the SAML document is not validated against an XML schema. This allows invalid XML documents to trick the verification process, by presenting elements with a valid signature inside elements whose content has been malformed. The verification is offloaded to xmlsec1 and xmlsec1 will not validate every signature in the given document, but only the first it finds in the given scope.

References

CVSS Scores

version 3.1
Expand this section

Snyk

5.4 medium
  • Attack Vector (AV)
    Network
  • Attack Complexity (AC)
    High
  • Privileges Required (PR)
    Low
  • User Interaction (UI)
    Required
  • Scope (S)
    Unchanged
  • Confidentiality (C)
    Low
  • Integrity (I)
    High
  • Availability (A)
    None
Expand this section

NVD

6.5 medium
Expand this section

Red Hat

6.5 medium