Server-Side Request Forgery (SSRF) Affecting sentry package, versions [9.1.0,]


0.0
medium

Snyk CVSS

    Attack Complexity Low

    Threat Intelligence

    EPSS 0.05% (18th percentile)
Expand this section
NVD
5.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PYTHON-SENTRY-6239652
  • published 9 Feb 2024
  • disclosed 9 Feb 2024
  • credit Unknown

How to fix?

A fix was pushed into the master branch but not yet published.

Overview

Affected versions of this package are vulnerable to Server-Side Request Forgery (SSRF) via Phabricator integration, which does not properly sanitize input. An attacker could exploit this by making the application send POST HTTP requests to arbitrary URLs, including internal IP addresses. This could allow the attacker to interact with the internal network or scan local/remote ports.

Note:

This is only exploitable if an attacker has access to a Sentry instance.