Directory Traversal Affecting plexus-archiver package, versions <0:2.4.2-5.el7_5


Severity

Recommended
0.0
high
0
10

Based on Red Hat Enterprise Linux security rating.

Threat Intelligence

EPSS
11.58% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RHEL7-PLEXUSARCHIVER-4812112
  • published26 Jul 2021
  • disclosed5 Jun 2018

Introduced: 5 Jun 2018

CVE-2018-1002200  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade RHEL:7 plexus-archiver to version 0:2.4.2-5.el7_5 or higher.
This issue was patched in RHSA-2018:1836.

NVD Description

Note: Versions mentioned in the description apply only to the upstream plexus-archiver package and not the plexus-archiver package as distributed by RHEL. See How to fix? for RHEL:7 relevant fixed versions and status.

plexus-archiver before 3.6.0 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in an archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.