Information Exposure Affecting actionpack package, versions <5.2.6.2 >=6.0.0.0, <6.0.4.6 >=6.1.0.0, <6.1.4.6 >=7.0.0.0, <7.0.2.2


0.0
high
  • Attack Complexity

    High

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-ACTIONPACK-2400638

  • published

    13 Feb 2022

  • disclosed

    13 Feb 2022

  • credit

    Jean Boussier

How to fix?

Upgrade actionpack to version 5.2.6.2, 6.0.4.6, 6.1.4.6, 7.0.2.2 or higher.

Overview

Affected versions of this package are vulnerable to Information Exposure via the ActionDispatch::Executor function, which expects response bodies to be closed and will not know to reset a thread's local state for the next request in a case where a response body isn't closed, allowing for data in the current request to leak to a subsequent request.