Cross-site Request Forgery (CSRF) Affecting actionpack package, versions <5.2.4.3 >=6.0.0, <6.0.3.1


0.0
medium
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    Low

  • User Interaction

    Required

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-ACTIONPACK-569599

  • published

    19 May 2020

  • disclosed

    19 May 2020

  • credit

    Unknown

How to fix?

Upgrade actionpack to version 5.2.4.3, 6.0.3.1 or higher.

Overview

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF) given a global CSRF token such as the one present in the authenticity_token meta tag.