Improper Authorization Affecting actionpack package, versions >=6.0.0, <6.0.3.2


0.0
high
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-ACTIONPACK-572498

  • published

    17 Jun 2020

  • disclosed

    17 Jun 2020

  • credit

    Unknown

How to fix?

Upgrade actionpack to version 6.0.3.2 or higher.

Overview

Affected versions of this package are vulnerable to Improper Authorization. By default, an attacker is able to execute any migrations that are pending for a Rails app running in production mode.