SQL Injection Affecting activerecord package, versions < 3.2.10, >= 3.2 < 3.1.9, >= 3.1 < 3.0.18


0.0
high
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-ACTIVERECORD-20044

  • published

    21 Dec 2012

  • disclosed

    21 Dec 2012

  • credit

    Unknown

How to fix?

Upgrade activerecord to versions 3.2.10, 3.1.9, 3.0.18 or higher.

Overview

ActiveRecord is the Object-Relational Mapping (ORM) that comes out-of-the-box with Rails. It plays the role of Model in the MVC architecture employed by Rails.

Affected versions of this package are vulnerable to SQL Injection. Due to the way dynamic finders in ActiveRecord extract options from method parameters, a method parameter can mistakenly be used as a scope. Carefully crafted requests can use the scope to inject arbitrary SQL.