Access Restriction Bypass Affecting activerecord package, versions < 3.2.12, >= 3.2 < 3.1.11, >= 2.4 < 2.3.17


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-ACTIVERECORD-20062

  • published

    10 Feb 2013

  • disclosed

    10 Feb 2013

  • credit

    Unknown

How to fix?

Upgrade ActiveRecord to versions 2.3.17, 2.4, 3.2 or higher.

Overview

ActiveRecord is the Object-Relational Mapping (ORM) that comes out-of-the-box with Rails. It plays the role of Model in the MVC architecture employed by Rails.

Affected versions of this package are vulnerable to Access Restriction Bypass via the attr_protected method of the Active Record. The issue is triggered during the handling of a specially crafted request, which may allow a remote attacker to bypass protection mechanisms and alter values that would otherwise be protected.