Arbitrary Data Injection Affecting activerecord package, versions < 4.1.5, >= 4.1 < 4.0.9, >= 4.0.0

  • Attack Complexity


Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id


  • published

    17 Aug 2014

  • disclosed

    17 Aug 2014

  • credit

    Stephen Touset

How to fix?

Upgrade ActiveRecord to version 4.0.9, 4.1.5 or higher.


ActiveRecord is the Object-Relational Mapping (ORM) that comes out-of-the-box with Rails. It plays the role of Model in the MVC architecture employed by Rails.

Affected versions of this package are vulnerable to Arbitrary Data Injection. The create_with functionality in ActiveRecord was implemented incorrectly and completely bypasses the strong parameters protection. Applications which pass user-controlled values to create_with could allow attackers to set arbitrary attributes on models.