Remote Code Execution (RCE) Affecting activerecord package, versions <5.2.8.1 >=6.0.0, <6.0.5.1 >=6.1.0, <6.1.6.1 >=7.0.0, <7.0.3.1


0.0
critical
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-ACTIVERECORD-2960802

  • published

    13 Jul 2022

  • disclosed

    13 Jul 2022

  • credit

    @elebow

How to fix?

Upgrade activerecord to version 5.2.8.1, 6.0.5.1, 6.1.6.1, 7.0.3.1 or higher.

Overview

activerecord is a library for databases on Rails.

Affected versions of this package are vulnerable to Remote Code Execution (RCE). When serialized columns that use YAML (the default) are deserialized, Rails uses YAML.unsafe_load to convert the YAML data in to Ruby objects. If an attacker can manipulate data in the database (via means like SQL injection), then it may be possible for the attacker to escalate to an RCE.