SQL Injection Affecting activerecord package, versions >=2.0.0, <2.3.13 >=3.0.0, <3.0.10 >=3.1.0.beta1, <3.1.0.rc6


0.0
high
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-ACTIVERECORD-536100

  • published

    26 Nov 2019

  • disclosed

    29 Aug 2011

  • credit

    Unknown

How to fix?

Upgrade activerecord to version 2.3.13, 3.0.10, 3.1.0.rc6 or higher.

Overview

activerecord is a library for databases on Rails.

Affected versions of this package are vulnerable to SQL Injection. The quote_table_name method in the ActiveRecord adapters in activerecord/lib/active_record/connection_adapters/ allows remote attackers to execute arbitrary SQL commands via a crafted column name.