Arbitrary Code Injection Affecting activestorage Open this link in a new tab package, versions >=5.2.0, <5.2.6.3 >=6.0.0, <6.0.4.7 >=6.1.0, <6.1.4.7 >=7.0.0, <7.0.2.3


0.0
high
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    High

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-ACTIVESTORAGE-2420035

  • published

    9 Mar 2022

  • disclosed

    9 Mar 2022

  • credit

    gquadros, Zack Deveau

How to fix?

Upgrade activestorage to version 5.2.6.3, 6.0.4.7, 6.1.4.7, 7.0.2.3 or higher.

Overview

Affected versions of this package are vulnerable to Arbitrary Code Injection where the transformation method or its arguments are untrusted arbitrary input.

Note:

This vulnerability impacts applications that use Active Storage with the image_processing processing in addition to the mini_magick back end for image_processing.

PoC:

<%= image_tag blob.variant(params[:t] => params[:v]) %>