Improper Validation Affecting activestorage package, versions <5.2.4.3 >=6.0.0, <6.0.3.1


0.0
medium

Snyk CVSS

    Attack Complexity Low
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RUBY-ACTIVESTORAGE-569602
  • published 19 May 2020
  • disclosed 19 May 2020
  • credit Unknown

How to fix?

Upgrade activestorage to version 5.2.4.3, 6.0.3.1 or higher.

Overview

Affected versions of this package are vulnerable to Improper Validation. Utilizing this vulnerability, an attacker can control the Content-Length of an S3 direct upload URL without receiving a new signature from the server. This could be used to bypass controls in place on the server to limit upload size.