Information Exposure Affecting bolt package, versions <3.24.0


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Scope

    Changed

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-BOLT-2953388

  • published

    20 Jul 2022

  • disclosed

    20 Jul 2022

  • credit

    Unknown

How to fix?

Upgrade bolt to version 3.24.0 or higher.

Overview

bolt is a library enabling the execution of commands remotely over SSH and WinRM

Affected versions of this package are vulnerable to Information Exposure when running the plan_start command, which returns and logs sensitive parameters.