Buffer Overflow Affecting cgi package, versions <0.3.1 >=0.2.0, <0.2.1 >=0.1.0, <0.1.1



    Attack Complexity Low

    Threat Intelligence

    Exploit Maturity Proof of concept
    EPSS 0.81% (82nd percentile)
Expand this section
9.8 critical
Expand this section
Red Hat
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RUBY-CGI-1930667
  • published 25 Nov 2021
  • disclosed 25 Nov 2021
  • credit chamal

How to fix?

Upgrade cgi to version 0.3.1, 0.2.1, 0.1.1 or higher.


cgi is a Support for the Common Gateway Interface protocol.

Affected versions of this package are vulnerable to Buffer Overflow when a very large string (> 700 MB) is passed to CGI.escape_html on a platform where long type takes 4 bytes.