Command Injection Affecting cocoapods-downloader Open this link in a new tab package, versions <1.6.0 >=1.6.2, <1.6.3


0.0
high
  • Attack Complexity

    High

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-COCOAPODSDOWNLOADER-2414278

  • published

    1 Apr 2022

  • disclosed

    2 Mar 2022

  • credit

    Alessio Della Libera of Snyk Research Team

How to fix?

Upgrade cocoapods-downloader to version 1.6.0, 1.6.3 or higher.

Overview

cocoapods-downloader is an A small library for downloading files from remotes in a folder.

Affected versions of this package are vulnerable to Command Injection via git argument injection. When calling the Pod::Downloader.preprocess_options function and using git, both the git and branch parameters are passed to the git ls-remote subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.

References