Interpretation Conflict Affecting crass package, versions <1.0.8


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.35% (29th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-RUBY-CRASS-22132611
  • published2 Nov 2026
  • disclosed28 Oct 2026
  • creditUnknown

Introduced: 28 Oct 2026

NewCVE-2026-116695  (opens in a new tab)
CWE-436  (opens in a new tab)

How to fix?

Upgrade crass to version 1.0.8 or higher.

Overview

Affected versions of this package are vulnerable to Interpretation Conflict in the tokenizer process. An attacker can inject arbitrary CSS declarations, style rules, or at-rules by crafting malicious CSS input that exploits incorrect tokenization of bad URLs, potentially bypassing sanitizers and leading to UI redress, loading of external resources, or CSS-based data exfiltration.

CVSS Base Scores

version 4.0
version 3.1