SQL Injection Affecting curupira package, versions <0.1.4


0.0
medium
0
10

Snyk CVSS

    Attack Complexity Low

    Threat Intelligence

    EPSS 0.14% (50th percentile)
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RUBY-CURUPIRA-3231516
  • published 16 Jan 2023
  • disclosed 16 Jan 2023
  • credit Unknown

How to fix?

Upgrade curupira to version 0.1.4 or higher.

Overview

Affected versions of this package are vulnerable to SQL Injection via the create() function, by manipulating the @user field.