Remote Code Execution (RCE) Affecting diffy package, versions <3.4.1



    Attack Complexity High
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 0.19% (56th percentile)
Expand this section
9.8 critical
Expand this section
Red Hat
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RUBY-DIFFY-2934981
  • published 24 Jun 2022
  • disclosed 24 Jun 2022
  • credit Unknown

How to fix?

Upgrade diffy to version 3.4.1 or higher.


diffy is a Convenient diffing gem in ruby.

Affected versions of this package are vulnerable to Remote Code Execution (RCE). The function that calls the diff tool does not properly handle double quotes in a filename when run in a windows environment. This allows attackers to execute arbitrary commands via a crafted string.

Note: This vulnerability is applicable in Windows only.