Arbitrary Command Execution Affecting dragonfly package, versions < 1.0.7


Severity

Recommended
0.0
high
0
10

CVSS assessment made by Snyk's Security Team

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-RUBY-DRAGONFLY-20193
  • published 24 Aug 2014
  • disclosed 24 Aug 2014
  • credit Unknown

Introduced: 24 Aug 2014

CVE NOT AVAILABLE CWE-77 Open this link in a new tab

Overview

dragonfly is a framework that enables on-the-fly processing for any content type. This gem was renamed from fog-dragonfly to dragonfly.

Affected versions of this gem are vulnerable to a remote attacker gaining read/write access to the filesystem, and executing arbitrary commands via a flaw in uploading & processing. This is that is due to the gem failing to restrict arbitrary commands to imagemagicks convert.

Related to SNYK-RUBY-DRAGONFLY-20192

CVSS Scores

version 3.1
Expand this section

Snyk

7.3 high
  • Attack Vector (AV)
    Network
  • Attack Complexity (AC)
    Low
  • Privileges Required (PR)
    None
  • User Interaction (UI)
    None
  • Scope (S)
    Unchanged
  • Confidentiality (C)
    Low
  • Integrity (I)
    Low
  • Availability (A)
    Low